Thursday, May 12, 2011

Setting up WiKID Community Edition on Ubuntu 10.04

I worked this up over the last couple of days.

#update system
sudo apt-get update
sudo apt-get upgrade

#update respositories to get sun-java6-jdk installed
sudo cp /etc/apt/sources.list /etc/apt/sources.list.backup
sudo nano /etc/apt/sources.list
#clear the "#" from the line deb lucid partner and save the file
sudo apt-get update
#install the java jdk, you will need to accept the license
sudo apt-get install sun-java6-jdk
# this installs the following packages
# avahi-daemon consolekit dbus defoma gsfonts gsfonts-x11 java-common libasound2 libavahi-common-data libavahi-common3 libavahi-core6 libck-connector0 libdaemon0 libeggdbus-1-0 libfontenc1 libltdl7 libnss-mdns libpam-ck-connector libpolkit-gobject-1-0 libxfont1 libxi6 libxtst6 odbcinst odbcinst1debian1 sun-java6-bin sun-java6-jdk sun-java6-jre unixodbc x11-common xfonts-encodings xfonts-utils

#create a logical link to /opt/java from /usr/lib/jvm/java-6-sun
sudo ln -s /usr/lib/jvm/java-6-sun /opt/java

#install the WikID Community Edition prerequisites
sudo apt-get install postgresql libpg-java libpg-perl libwww-perl ntp alien wget iptables
#The following NEW packages will be installed:
# alien binutils build-essential cvs debhelper dpkg-dev fakeroot g++ g++-4.4 gcc gcc-4.4 gettext html2text intltool-debian libc-dev-bin libc6-dev libcroco3 libfile-copy-recursive-perl libgomp1 liblua5.1-0 liblzma1 libmail-sendmail-perl libnspr4-0d libnss3-1d libpg-java libpg-perl libpq5 librpm0 librpmbuild0 librpmio0 libstdc++6-4.4-dev libsys-hostname-long-perl linux-libc-dev manpages-dev ntp po-debconf postgresql postgresql-8.4 postgresql-client-8.4 postgresql-client-common postgresql-common rpm rpm-common rpm2cpio ssl-cert update-inetd xz-utils

#connect to the database to set the password
sudo -u postgres psql postgres
#set the password for the postgres role
\password postgress

#download the deb files
#you may need to move the file to a new name
mv wikid-server-community_3.4.87-b824-1.deb? wikid-server-community_3.4.87-b824-1.deb
#run dpkg once to prep the install
sudo dpkg -i wikid-server-community_3.4.87-b824-1.deb
#this will fail the first time
#run a dependency update
sudo apt-get -f install
#The following NEW packages will be installed:
# ca-certificates-java fontconfig fontconfig-config hicolor-icon-theme icedtea-6-jre-cacao libaccess-bridge-java libaccess-bridge-java-jni libatk1.0-0 libatk1.0-data libavahi-client3 libcairo2 libcups2 libdatrie1 libdirectfb-1.2-0 libflac8 libfontconfig1 libgif4 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libice-dev libice6 libjasper1 libjpeg62 liblcms1 libogg0 libpango1.0-0 libpango1.0-common libpixman-1-0 libpthread-stubs0 libpthread-stubs0-dev libpulse0 libsm-dev libsm6 libsndfile1 libsysfs2 libthai-data libthai0 libtiff4 libts-0.0-0 libvorbis0a libvorbisenc2 libx11-dev libxau-dev libxcb-render-util0 libxcb-render0 libxcb1-dev libxcomposite1 libxcursor1 libxdamage1 libxdmcp-dev libxfixes3 libxft2 libxinerama1 libxrandr2 libxrender1 libxt-dev libxt6 openjdk-6-jdk openjdk-6-jre openjdk-6-jre-headless openjdk-6-jre-lib shared-mime-info tsconf ttf-dejavu-core ttf-dejavu-extra tzdata-java x-ttcidfont-conf x11proto-core-dev x11proto-input-dev x11proto-kb-dev xtrans-dev
#run dpkg again to install the package
sudo dpkg -i wikid-server-community_3.4.87-b824-1.deb
# run the configuration
sudo /opt/WiKID/sbin/
# firstboot config
sudo /opt/WiKID/conf/templates/
#run the configuration wizard
sudo /opt/WiKID/bin/wikidctl setup
#start the services
sudo /opt/WiKID/bin/wikidctl start

#Connect to the WiKID Admin interface

username: WiKIDAdmin
passowrd: 2Factor

#Follow the instructions for set up for WiKID Community Edition

WiKID posted a similar version on their web site - - which cuts out a few of the steps that I have above.

Be safe out there.